1. 03 Aug, 2017 1 commit
    • Cedric Roux's avatar
      bugfix for phy simulators (not sure if enough) · 9e4f700a
      Cedric Roux authored
      With the new threading architecture of the UE dlsim
      (and others) does not work properly anymore.
      
      When looking at the scope, you see a difference
      in PDSCH LLR display. The end is always 0 where
      in the current develop branch (tag 2017.w25) it's not.
      
      This commit attempts to fix it.
      
      We still don't have the same behavior as in 2017.w25.
      I disabled channel simulation (so that UE RX = eNB TX)
      and I have one error where in 2017.w25 I have zero.
      For example, here comes the output of a run of "./dlsim":
      
      **********************SNR = 0.000000 dB (tx_lev 51.000000)**************************
      Errors (1(0)/1000 0/1 0/0 0/0), Pe = (1.000000e-03,0.000000e+00,-nan,-nan), dci_errors 0/1001, Pe = 0.000000e+00 => effective rate 99.900100, normalized delay 0.001472 (1.001000)
      
      And in 2017.w25 we have (with the same hack to disable
      channel simulation):
      
      **********************SNR = 0.000000 dB (tx_lev 51.000000)**************************
      Errors (0(0)/1000 0/0 0/0 0/0), Pe = (0.000000e+00,-nan,-nan,-nan), dci_errors 0/1000, Pe = 0.000000e+00 => effective rate 100.000000, normalized delay 0.001471 (1.000000)
      
      There may be a problem somewhere. Or there was one before and we should
      have had one error and the new UE architecture fixed things and now
      it's as it has to be. Hard to say at this point...
      
      When looking at the scope we quickly see some zeros for the PDSCH
      LLR, at the begining this time, not at the end. This is just when
      the GUI appears and then all is fine, so this seems to be for the
      first frame only. In 2017.w25 this does not happen.
      9e4f700a
  2. 01 Aug, 2017 1 commit
  3. 31 Jul, 2017 3 commits
  4. 28 Jul, 2017 1 commit
  5. 27 Jul, 2017 1 commit
    • Cedric Roux's avatar
      bugfix: fix bug "Unknown UE_id for rnti" · 8d5901c8
      Cedric Roux authored
      This bug happens when we detect uplink failure for one UE.
      In this case, a DCI format 1A is sent to the UE to ask it
      to do random acces.
      
      The way this DCI is generated was not compatible with how
      the software is organized. It was expected that the DCI are
      added (with add_ue_spec_dci and add_common_dci) in a very
      specific order: first all DCIs in common space are added
      (with add_common_dci) then all DCIs in UE specific space
      are added (with add_ue_spec_dci).
      
      The problem was that the DCI format 1A DCI sent to the UE
      for it to do random access is added (with add_ue_spec_dci)
      before the DCIs in common space.
      
      That totally messed up the logic in add_common_dci and
      add_ue_spec_dci.
      
      The solution is to get rid of Num_common_dci and Num_ue_spec_dci,
      replace those two counters by only one (Num_dci) and add
      "search_space" in the dci_alloc structure to be used later by
      the function "allocate_CCEs" when calling "get_nCCE_offset".
      
      The software had to be adapted to the new variables, everywhere.
      
      I am not sure that the simulators work. It seems that some
      of them didn't use Num_common_dci and Num_ue_spec_dci to
      decide on what space (common or UE specific) to put the DCI,
      but relied on the rnti (comparing with SI_RNTI). To be tested
      properly.
      
      The modified simulators are:
        - openair1/SIMULATION/LTE_PHY/dlsim.c
        - openair1/SIMULATION/LTE_PHY/dlsim_tm4.c
        - openair1/SIMULATION/LTE_PHY/dlsim_tm7.c
        - openair1/SIMULATION/LTE_PHY/framegen.c
        - openair1/SIMULATION/LTE_PHY/pdcchsim.c
        - openair1/SIMULATION/LTE_PHY/syncsim.c
      8d5901c8
  6. 26 Jul, 2017 1 commit
  7. 20 Jul, 2017 1 commit
  8. 17 Jul, 2017 3 commits
  9. 06 Jul, 2017 1 commit
  10. 04 Jul, 2017 1 commit
  11. 29 Jun, 2017 1 commit
  12. 28 Jun, 2017 1 commit
  13. 27 Jun, 2017 1 commit
  14. 21 Jun, 2017 3 commits
  15. 16 Jun, 2017 2 commits
  16. 15 Jun, 2017 2 commits
  17. 14 Jun, 2017 1 commit
  18. 13 Jun, 2017 3 commits
  19. 12 Jun, 2017 3 commits
  20. 08 Jun, 2017 3 commits
  21. 07 Jun, 2017 3 commits
  22. 02 Jun, 2017 1 commit
    • Cedric Roux's avatar
      integration fixes · 60c4b5ec
      Cedric Roux authored
      - rename UE_NO_LOG to DISABLE_LOG_X
        because the name is misleading. The full software
        is impacted, not only the UE part
      - same for compilation option ---ue-no-log
        that becomes --disable-log
      - keep LOG_X for the standard case, that is the
        case without DISABLE_LOG_X where printf has been
        put. Two reasons:
        * printf is not realtime friendly
        * keep behavior similar for other users who may
          be troubled by different logs that don't add
          any benefit to previous logs
      60c4b5ec
  23. 29 May, 2017 1 commit
  24. 24 May, 2017 1 commit