Commit 1fe8ef6c authored by nikaeinn's avatar nikaeinn

* add oaisim walkthrough document in targets/DOCS

* update the targets/README.txt
* fix the pdcp timing stats for eNB in oaisim


git-svn-id: http://svn.eurecom.fr/openair4G/trunk@5223 818b1a75-f10b-46b9-bf7c-635c3b92a50f
parent e7921f03
......@@ -19,6 +19,7 @@ First, you must have all four openair SW directories, openair1, openair2, openai
- libgtk-3-dev
- libxml2 and libxml2-dev and gccxml
- libforms-bin libforms-dev
- nettle-dev nettle-bin openssl
- libatlas-base-dev and libatlas-headers (for Ubuntu 11.04, libatlas-dev instead of libatlas-headers)
- asn1c and the LTE ASN1 files (for more information on how to install this and generate the required files see the README file in openair2/RRC/LITE/MESSAGES)
......@@ -64,3 +65,17 @@ The 3 folders have the following structures
+ after the line: %admin ALL=(ALL) ALL, add : user_name ALL=(ALL) NOPASSWD: ALL
- include this line: alias sudo='sudo -E', to the .bashrc
- run oai as follows: sudo ./oaisim arg1 arg2 ....
----------------------------------------------------------------
4) Detail Instructions
----------------------------------------------------------------
Please follow the instructions given in DOCS/oaisim_walkthrough.pdf
----------------------------------------------------------------
5) OAI on virtual machine
----------------------------------------------------------------
you may download the image using this URL: https://emu.openairinterface.org/openairlab/openairlab.zip
chekc that all the packges are there as some packages might be added later.
......@@ -188,11 +188,11 @@ endif
ifdef SECU
ifeq ($(NETTLE_FOUND), 0)
@echo "Nettle library >= 2.5 is not installed on your system, continuing with security disabled"
@echo "Nettle library >= 2.5 is not installed on your system, nettle-dev lib needed, continuing with security disabled"
SECU=0
else
ifeq ($(OPENSSL_FOUND), 0)
@echo "openssl library is not installed on your system, continuing with security disabled"
@echo "openssl library is not installed on your system, openssl lib needed, continuing with security disabled"
SECU=0
else
CFLAGS += -DENABLE_SECURITY
......
......@@ -1303,9 +1303,9 @@ void reset_opp_meas(void){
reset_meas(&eNB_mac_inst[eNB_id].schedule_mch); // only embms
reset_meas(&eNB_mac_inst[eNB_id].rx_ulsch_sdu); // include rlc_data_ind + mac header parser
reset_meas(&eNB_pdcp_stats[UE_id].pdcp_run);
reset_meas(&eNB_pdcp_stats[UE_id].data_req);
reset_meas(&eNB_pdcp_stats[UE_id].data_ind);
reset_meas(&eNB_pdcp_stats[eNB_id].pdcp_run);
reset_meas(&eNB_pdcp_stats[eNB_id].data_req);
reset_meas(&eNB_pdcp_stats[eNB_id].data_ind);
/*
reset_meas(&eNB_pdcp_stats[UE_id].encrption);
reset_meas(&eNB_pdcp_stats[UE_id].decrption);
......@@ -1436,9 +1436,9 @@ void print_opp_meas(void){
print_meas(&eNB_mac_inst[eNB_id].schedule_ulsch,"[eNB][UL][ULSCH]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_mac_inst[eNB_id].rx_ulsch_sdu,"[eNB][UL][rx_ulsch_sdu]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[UE_id].pdcp_run,"[eNB][pdcp_run]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[UE_id].data_req,"[eNB][DL][pdcp_data_req]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[UE_id].data_ind,"[eNB][UL][pdcp_data_ind]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[eNB_id].pdcp_run,"[eNB][pdcp_run]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[eNB_id].data_req,"[eNB][DL][pdcp_data_req]",&oaisim_stats,&oaisim_stats_f);
print_meas(&eNB_pdcp_stats[eNB_id].data_ind,"[eNB][UL][pdcp_data_ind]",&oaisim_stats,&oaisim_stats_f);
}
}
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment