Commit cc79250f authored by oai's avatar oai

Fix configuration module shared library improperly build and not loadable when...

Fix configuration module shared library improperly build and not loadable when libconfig version is below 1.5
parent 7ea7891b
......@@ -11,6 +11,10 @@
#include "../config_userapi.h"
#include "errno.h"
#if ( LIBCONFIG_VER_MAJOR == 1 && LIBCONFIG_VER_MINOR < 5)
#define config_setting_lookup config_lookup_from
#endif
void config_libconfig_end(void );
int read_strlist(paramdef_t *cfgoptions,config_setting_t *setting, char *cfgpath)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment