Commit 8b8cc983 authored by thomasl's avatar thomasl

ifix netle install: reverse if version = 12.04 to != 12.04 (I guess it is the initial intention)

fix ssh-server install: start servce after installation (else it doesn't start in ubuntu 14.04 at least)



git-svn-id: http://svn.eurecom.fr/openair4G/trunk@6039 818b1a75-f10b-46b9-bf7c-635c3b92a50f
parent a1ccea0c
...@@ -294,6 +294,7 @@ check_install_oai_software() { ...@@ -294,6 +294,7 @@ check_install_oai_software() {
test_install_package cmake test_install_package cmake
test_install_package openssh-client test_install_package openssh-client
test_install_package openssh-server test_install_package openssh-server
sudo service ssh start
test_install_package unzip test_install_package unzip
test_install_package autoconf test_install_package autoconf
test_install_package automake test_install_package automake
...@@ -361,7 +362,7 @@ check_install_oai_software() { ...@@ -361,7 +362,7 @@ check_install_oai_software() {
check_install_hss_software() { check_install_hss_software() {
if [ ! -f ./.lock_oaibuild ]; then if [ ! -f ./.lock_oaibuild ]; then
$SUDO apt-get update $SUDO apt-get update
if [ $UBUNTU_REL = "12.04" ]; then if [ $UBUNTU_REL != "12.04" ]; then
test_uninstall_package nettle-dev test_uninstall_package nettle-dev
test_uninstall_package nettle-bin test_uninstall_package nettle-bin
fi fi
...@@ -394,6 +395,7 @@ check_install_hss_software() { ...@@ -394,6 +395,7 @@ check_install_hss_software() {
test_install_package mysql-server-5.5 test_install_package mysql-server-5.5
test_install_package openssh-client test_install_package openssh-client
test_install_package openssh-server test_install_package openssh-server
sudo service ssh start
test_install_package phpmyadmin test_install_package phpmyadmin
test_install_package python-dev test_install_package python-dev
test_install_package sshfs test_install_package sshfs
...@@ -417,7 +419,7 @@ check_install_epc_software() { ...@@ -417,7 +419,7 @@ check_install_epc_software() {
if [ ! -f ./.lock_oaibuild ]; then if [ ! -f ./.lock_oaibuild ]; then
$SUDO apt-get update $SUDO apt-get update
if [ $UBUNTU_REL = "12.04" ]; then if [ $UBUNTU_REL != "12.04" ]; then
test_uninstall_package nettle-dev test_uninstall_package nettle-dev
test_uninstall_package nettle-bin test_uninstall_package nettle-bin
fi fi
...@@ -468,6 +470,7 @@ check_install_epc_software() { ...@@ -468,6 +470,7 @@ check_install_epc_software() {
test_install_package make test_install_package make
test_install_package openssh-client test_install_package openssh-client
test_install_package openssh-server test_install_package openssh-server
sudo service ssh start
test_install_package openssl test_install_package openssl
test_install_package openvpn test_install_package openvpn
test_install_package pkg-config test_install_package pkg-config
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment