Commit 9e8ad492 authored by Cedric Roux's avatar Cedric Roux

fix install on centOS

- install package 'vim-common' to have 'xxd' needed by the compilation
  process of the T tracer
- change the way xxd is called so that no file is created in case
  of error
parent 86c199e3
Pipeline #10233 passed with stage
in 0 seconds
......@@ -597,7 +597,7 @@ check_install_oai_software() {
echo "EPEL repos not present. Installing them."
$SUDO $INSTALLER install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
fi
$SUDO $INSTALLER install -y python-epdb
$SUDO $INSTALLER install -y python-epdb vim-common
else
$SUDO $INSTALLER install -y mscgen pydb
fi
......
......@@ -13,7 +13,7 @@ $(GENIDS): $(GENIDS_OBJS)
$(CC) $(CFLAGS) -c -o $@ $<
T_messages.txt.h: T_messages.txt
xxd -i T_messages.txt > T_messages.txt.h
xxd -i T_messages.txt T_messages.txt.h
T_IDs.h: $(GENIDS) T_messages.txt
./$(GENIDS) T_messages.txt T_IDs.h
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment