1. 23 Aug, 2017 1 commit
    • Cedric Roux's avatar
      mobipass standalone driver · c866677a
      Cedric Roux authored
      How to use:
      
      1 - compilation of softmodem:
        ./build_oai --eNB -t ETHERNET
      
      2 - compilation of mobipass driver:
        cd cmake_targets/lte_build_oai/build
        make oai_mobipass
        ln -sf liboai_mobipass.so liboai_transpro.so
      
      3 - configuration:
        edit the configuration file, set "node_timing" to
        "synch_to_mobipass_standalone"
        that is, have the line:
          node_timing               = "synch_to_mobipass_standalone";
      
      4 - run:
        run as usual: sudo ./lte-softmodem -C <configuration file>
      c866677a
  2. 22 Aug, 2017 1 commit
  3. 18 Aug, 2017 3 commits
  4. 23 Jun, 2017 2 commits
    • Cedric Roux's avatar
      bladerf: minor: add log for RX overrun · a8ae85f6
      Cedric Roux authored
      a8ae85f6
    • Cedric Roux's avatar
      bladerf: tentative to have it functional · 0da60274
      Cedric Roux authored
      Several problems are present.
      
      The first is that _write returns 0 instead of the
      number of samples. We solve it by returning
      nsamps.
      
      The second is that _read may return less samples at
      the beginning and we don't want to exit for that.
      We solve it also by returning nsamps.
      (We still need to log more in this, to be done in the
      next commit.)
      
      The third is that after initialization we don't send
      anything for a while, time for the softmodem to finish
      its init. This generates lots of "RX overrun".
      We solve it by disabling TX and RX modules after init
      and then in trx_brf_start we activate them again (and
      also call bladerf_sync_config, which seems to be
      mandatory, and bladerf_calibrate_dc, which may be avoided,
      perhaps).
      
      Maybe not the end of the story. Sometimes it works, UE connects,
      traffic is fine (tested only with 5MHz). Sometimes it does not,
      UE does not connect, or it connects but then traffic is bad,
      especially uplink.
      
      To be refined.
      0da60274
  5. 22 May, 2017 1 commit
  6. 18 May, 2017 1 commit
  7. 15 May, 2017 1 commit
  8. 27 Mar, 2017 1 commit
    • Cedric Roux's avatar
      bugfix: workaround a problem with timestamp and LMSSDR. · fa0b8668
      Cedric Roux authored
      We have a strange problem with the timestamp of the very
      first packets received from the LimeSDR that leads to
      a complete failure of the eNB.
      
      A simple workaround is to discard the first RX packet
      just after a "start" of the device.
      
      We also change the value of "tx_sample_advance" to a more
      reasonable value. The problem of timestamp was "solved"
      differently in the past and at the time we needed to put
      a much higher value.
      
      This may have to be refined at some point.
      fa0b8668
  9. 24 Mar, 2017 4 commits
  10. 16 Mar, 2017 1 commit
  11. 15 Mar, 2017 1 commit
  12. 09 Mar, 2017 1 commit
  13. 03 Mar, 2017 1 commit
  14. 01 Mar, 2017 1 commit
  15. 17 Feb, 2017 1 commit
  16. 14 Feb, 2017 1 commit
  17. 13 Feb, 2017 1 commit
  18. 10 Feb, 2017 3 commits
  19. 09 Feb, 2017 2 commits
  20. 02 Feb, 2017 1 commit
  21. 01 Feb, 2017 1 commit
  22. 29 Jan, 2017 1 commit
  23. 28 Jan, 2017 1 commit
  24. 18 Jan, 2017 3 commits
  25. 15 Jan, 2017 1 commit
  26. 13 Jan, 2017 1 commit
  27. 07 Jan, 2017 1 commit
  28. 03 Jan, 2017 2 commits