Commit 016d9d21 authored by Daniele Venzano's avatar Daniele Venzano

Enable docker-py version detection to prevent "client is newer than server" errors

parent 91e143eb
......@@ -134,7 +134,7 @@ class SwarmClient:
else:
raise ZoeLibException('Unsupported URL scheme for Swarm')
log.debug('Connecting to Swarm at {}'.format(manager))
self.cli = docker.Client(base_url=manager)
self.cli = docker.Client(base_url=manager, version="auto")
def info(self) -> SwarmStats:
"""Retrieve Swarm statistics. The Docker API returns a mess difficult to parse."""
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment